วิธี install Kma (kthai mikrotik api) ลงใน Appserv พร้อมแจก API Cloud

วิธี install ผมจะไม่ลงราย ละเอียดอะไรมากนะครับ ผมจะบอกคร่าวๆ สำหรับคนที่มี พื้น พวกเขียน Web อยู่แล้ว ก็ไม่ยาก นะครับ ไม่พูดพรํ่าทำเพลง มาลงมือกันดีกว่า 

รูปแรก เราสร้าง data base ตามรูปนะครับ ใส่ชือ data base แล้ว กด Create 


1

ผมสร้าง ชื่อ kthai_api

2

copy ทั้ง Folder หรือ จะ Copy เอาข้างในก็ได้ 

 

3

เอาไปวางที่ c:\Appserv\www\

4

เข้าไปที่ Localhost/ชื่อfolder/system/install

แล้ว กด Accept&Continue

5

 

6

ขั้นตอนนี้ให้เราใส่รายละเอียด Database ที่เราสร้าง ขึ้น แล้วแต่ละท่านจะตั้งยังไง

 

7

8

เข้าหน้า admin เพื่อจัดการหน้า CP อย่า ลืมลบ Folder install ออกก่อนนะครับ

 9

อยู่ตรงนี้นะครับ

 

10

หลังจากนั้นเข้าหน้า Admin ไปที่ http://localhost/kthai-api/admin/

 

11

 

12

 

ต่อมาเราก็มาเปลี่ยน ภาษาไทยก่อนนะครับ แปลโดย นาย กร อาจจะแปลไม่ค่อยเก่ง ไปที่ Settings ----->LOCALISATION

13

 

เลือก Thailand กด Save

14

 

แค่นี้ก็ได้เป็น ภาษาไทยแล้ว

15

 

 

 Password winrar : www.k-thai.net

Clip Video สอนการ install API Mikrotik บน Appserv

วิธี install API Mikrotik โดยละเอียด และ วิธี Add user กับ Userprofile สามารถ ออกเป็น QR Code ได้เลย สามารถ ดูรายละเอียด และ Download API Mikrotik ได้ที่

 Pass Winrar : www.k-thai.net ครับ

http://www.4shared.com/rar/7TXvh7b3ce/API-MIKROTIKNEW.html?

วิธี เก็บ log พ.ร.บ. Mikrotik โดยใช้ SyslogWatcherPersonal

วันนี้ผมจะมาสาธิตการ เก็บ Log ตาม พรบ นะครับโดยใช้ SyslogWatcherPersonal 

อันดับแรกเรา ก็  Download โปรแกรม พร้อม install ให้เรียบร้อยนะครับ 
2. หลังจากนั้น เข้าไปตั้งค่าตามนี้ครับ
1 1 

 

2

 

3

เข้าไปที่ system - loging เพิ่มที่เก็บ remote Address คือ เครื่องที่เราจะเอาไปเก็บ Port ตามนั้นเลยให้มันตรงกับ  โปรแกรม syslog

4

เพิ่ม ว่าจะให้เก็บอะไรบ้าง ขาดไม่ได้ Web-Proxy

5

ตั้งค่า Web-Proxy ไปที่ IP- Web-proxy Enabled ด้วยนะครับ

6

เพิ่ม NAT ใน firewall ด้วยนะครับ ตามนี้ 

7

 

8

ไปกำหนด ใส่ Script ใน Hotspot เข้าไปใน Profile ที่เราจัดการ

9

เอา Script วางได้เลย 

On login

:local whouser $user;
:local whoip $address;
:local macaddr [/ip hotspot active get [find user=$whouser] mac-address];

:log info (“User Login:”.$whouser.” IP :”.$whoip.” Mac:”.macaddr);

On logout

:log info (“User Logout: “.$user);

10

เป็นอันเสร็จ พิธีการ ผลที่ได้ก็ประมาณนี้ ครับ

11

Script ช่วยเตือนหรือป้องกันการแชร์อินเตอร์เน็ตสำหรับเครื่องที่เราไม่ต้องการ

สคริปช่วยเตือนหรือป้องกันการแชร์อินเตอร์เน็ตสำหรับเครื่องที่เราไม่ต้องการครับ หลักการคือถ้าaddress และ to-addressไม่เหมื่อนกันจะโดนสคริปเตะออกและถ้ามีการขอไอพีเพิ่ม จาก Mac address ที่เราไม่กำหนดมากกว่า1 สคริปจะทำการค้นหาและเตะuserที่มีการขอไอพีเพิ่มออกจากระบบ ถ้าขอไอพีบ่อยๆเราก็บล็อคได้ครับแล้วแต่จะปรับแต่งตามต้องการ สามารถปรับใช้ให้ส่งอิเมล์เตือนได้ครับ #อาจจะไม่100%เต็มนะครับ แต่พอช่วยได้ระดับหนึ่ง
link:
https://drive.google.com/…/0B520tVxRm4SjRTZTVXp3RGRaQ…/view…
ถ้าต้องการให้เตะuserที่ active ออกให้เอาเครื่องหมาย#ออกนะครับที่
#/ip hotspot active remove [find where mac-address=\$macaddr]อยู่ในสคริป

 

ใน file list สร้างโฟล์เดอร์ macaddress_hosts และนำไฟล์ mac_hosts.txt มาใส่เพื่อกำหนดmac address ที่เราต้องการให้ผ่านสคริปได้ เช่นเร้าเตอร์ที่เราต้องการ และ AP ที่เรากำหนดไอพีเอง

15822966 1294543890568986 1725559644455872046 n

สร้างโฟล์เดอร์ macaddress_hosts

15776834 1294543880568987 5296303849973210071 o

 

นำไฟล์ mac_hosts.txt ที่เราสร้างไว้มาใส่
15776835 1294543927235649 366253461789375441 o
ตัวอย่าง mac address ของเครื่องที่เราต้องการให้ผ่านสคริปได้
15823424 1294543920568983 423037095405332236 n
 
ตัวอย่าง host ที่ขอไอพีและตั้งไอพีเอง dynamic
15822637 1294543923902316 8243206500230955656 n
 
ตัวอย่างที่สคริปทำงานส่งมาทางอิเมล์ เตะuser a44629 ที่ขอไอพีมา 2ไอพีในเวลาเดียวกัน และต้อง login เข้าระบบใหม่ ผมสแกนหาปรากฏว่าแชร์wifi และ mac address ใกล้เคียงกัน และทำการ block mac addressนี้ ทีหลัง
15781788 1294543957235646 7744086182660482703 n
เครดิต : Cha Chi
 
 
 
 
 

 

เจอปัญหา ลืม Password Userman ไม่รู้จะ Reset ยังไงวันนี้ผมมี วิธีแก้มาบอกครับ

ตอนแรกผมก็หาวิธีแก้ไม่ได้ ลองหาข้อมูล ของอาจารย์ กู ท่านบอกว่า  ให้เอา Script นี้ไปใส่ใน Terminal Winbox 

12

/tool user-manager customer set admin password=PASSWORD 

13

เพียงเท่านี้ ท่านก็ Login หน้า Userman ได้แล้วครับ

 

เคยเจอปัญหา I phone I PAD เข้าใช้งาน Hotsport Mikrotik ไม่ได้อยู่หรือไม่ เรามีทางแก้

ท่านเคยเจอปัญหา Iphone ipad login เข้าหน้า hot Spot ไม่ได้อยู่หรือไม่ 
ผมเคยอยู่ ตอนนั้น ลูกค้า login ไม่ได้ก็คิดว่าเป็นที่ มือถือของลูกค้าเครื่องเดียว ที่ไหนได้เป็นทั้ง หอพัก 

ผมเลยค้นหาใน Google ดูมีฝาหรั่งบอกมา ว่าเป็นเพราะ mikrotik Block Iphone ให้เรา ไป  Allow ที่ Walled garden ใน hotspot
ผมเลยเขียน เป็น Script  Add Web ทั้งหมดของ Apple ซะเลย

/ip hotspot walled-garden
add dst-host=:^www.apple.com
add dst-host=:^www.airport.us
add dst-host=:^www.itools.info
add dst-host=:^www.appleiphonecell.com
add dst-host=:^captive.apple.com
add dst-host=:^www.thinkdifferent.us
add dst-host=:^www.ibook.info

ขั้งตอนที่ 1.เปิด terminal มา
เอา Script วาง
11mikrotik

หลังจากที่เราวาง Script ไปแล้ว ก็ขั้นอย่างมในรูป เป็นอันเสร็จสิ้น 

2mikrotik

ติดตั้ง ระบบ Police Crime และ ระบบ RTP

รับติดตั้งระบบ Polis & CRIMES ทั่วประเทศ ฝ่าน ระบบ Vpn ทำให้สะดวกในการทำงาน ของเจ้าหน้าที่ เป็นอย่างมาก ระบบนี้ ไม่ต้องคอยมาสลับสาย Internet และ Polis อีกต่อไป ไม่ว่าจะเป็นมือถือ หรือ Computer Notebook ก็สามารถ ทำงาน

ติดตั้ง Server ระบบ Polis VPN polis และระบบ Polis / Crimes /ประกันสังคม /LM2560 ที่ IOS 6 Iphone Ipad เข้าใช้งานได้สามารถเซ็คหมายจับได้ รับกู้ข้อมูล ระบบใหม่ของ Polis สามารถสั่ง Print จากมือถือ Smart Phone
ระบบใหม่ นี้ ไม่ต้องมี สาย Polis ก็สามารถ เข้าใช้งานได้เหมาะสำหรับ ป้อม และด่านตรวจ เซ็คหมายจับทะเบียนราษฎร์ ผ่านมือถือได้เลย ครับ
ราคา Server Polis Vpn เริ่มต้นที่ 5,000 บาท ไม่มีค่าบริการรายเดือนครับ

หมายจับหรือเอกสารอื่นๆ เครื่องพิมพ์ ก็ทำงานที่โรงพัก พูดง่ายๆคืออยู่ที่ไหนก็ Print ได้ ติดตั้ง Program MOI เซ็คทะเบียนราษฎร์ สำหรับท่านที่ ขาด Program MOI Smartcard และ LM 64 Bit ติดตั้ง AMI ความสามารถ พิเศษ สามารถเข้าใช้งานระบบ ระบบ crimes เซ็คประกันสังคมได้
ไป Download ที่ www.k-thai.net 0869905488 Line ID 2521770

(เฉพาะงานตำรวจ บุลคลทั่วไปอย่าโทรมานะครับ)

Contact Info

  • Kthai Technology Team .
  • No. 124/129 1 buengyitho  Thanyaburi District, Pathum Thani 12130.
  • (66) 86990-5488/ 086-990-5488
  • This email address is being protected from spambots. You need JavaScript enabled to view it.
Top
We use cookies to improve our website. By continuing to use this website, you are giving consent to cookies being used. More details…